November 29 Service Disruption
Incident Report for Anaplan
Postmortem

On November 29, 2018 at 3:04 p.m. PDT Anaplan experienced a service disruption causing API calls using Anaplan certificates for authentication to fail. This disruption impacted 10 customers. In our dedication to transparency, we would like to provide additional information around the cause as well as our plan to avoid this issue in the future

The service disruption was caused by a misconfiguration within our pre-production environment that affected the production service that hosts the certificate against which API calls are validated. This resulted in an incorrect certificate being applied to the production service, invalidating self-generated Anaplan certificates. This issue was quickly identified and resolved by reverting the production service to the previous certificate.

As corrective measures to prevent and mitigate against future occurrences we have implemented additional infrastructure and change management process improvements, including an additional layer of protection for version updates.

We understand the impact to your experience when interruptions occur, and we are working diligently to improve our systems and processes to avoid further issues. We appreciate your patience, and as always thank you for being a valued Anaplan customer.

Posted 6 months ago. Dec 04, 2018 - 07:59 PST

Resolved
We received reports of users Anaplan certificates expiring. The issue started at 3:04 PST and was resolved at 4:39 PST. We apologize for any inconvenience this may have caused. Further details will be provided in an RCA.
Posted 6 months ago. Nov 29, 2018 - 17:18 PST