Platform Alerts
Incident Report for Anaplan
Postmortem

On January 28, 2025, at about 20:00 UTC, we started getting customer cases about problems when trying to load UX pages and Apps. This issue impacted customers in us7: Anaplan Amazon Cloud Public — US and resulted in time-out errors.  

Although our alerting didn't immediately indicate a platform wide issue, a platform incident was declared at 21:46 UTC. Our investigation identified a number of failures in the logs relating to a dependent backend service. A review of the service identified that a release had been deployed earlier in the day. We rolled back the release and observed that the failures had ceased. Further checks were completed to ensure that the platform was fully functional. Full service was restored 22:51 UTC.  

Post incident, we reviewed the root cause and identified that the issue was unrelated to the release. Instead, we found that the backend service was unable to communicate with key infrastructure. This was the source of the failures we observed during the incident. Part of the rollback process initiated a restart of the backend service, which recycled the infrastructure on which the service was hosted. This allowed connectivity to be restored and the issues subsided.  

To prevent similar incidents and further improve service reliability, we are working to improve our alerting in this space. We are reviewing the possibility of simplifying the network path between the backend service and the infrastructure. We are also carrying out a thorough assessment of the backend service to improve tolerance of network connectivity issues.  

We understand the significant impact service interruptions may have on your business operations and we remain committed to maintaining stable, reliable performance. Our team continues to monitor all systems closely to ensure consistent service quality. 

If you have any further questions or concerns, please contact Anaplan Customer Care. Thank you for your patience during this situation and thank you for being an Anaplan customer.

Posted Feb 06, 2025 - 16:47 UTC

Resolved
We have confirmed that the issue is now resolved.

We deeply apologize for any impact this issue may have caused. We appreciate your patience and partnership as we worked through this issue.

We will follow up within 7 business days with a detailed root cause analysis (RCA) that will be shared on our Status Page. If you have any question or concerns, please do not hesitate to contact us at Anaplan Support.
Posted Jan 28, 2025 - 23:10 UTC
Monitoring
Service has now been restored; you should now be able to resume normal activities.

We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support. We will provide a final update to you when we consider this situation fully resolved.
Posted Jan 28, 2025 - 22:45 UTC
Investigating
Thank you for your patience as we continue to investigate this issue related NUX pages not loading as expected. We have identified the issue and are applying a fix. We will continue to provide updates every 30 minutes as we work to resolve this issue as quickly as possible.
Posted Jan 28, 2025 - 22:39 UTC
This incident affected: us7: Anaplan Amazon Cloud Public - US.