Platform Alerts

Incident Report for Anaplan

Postmortem

On February 25, 2026, at 23:25 UTC, we detected an issue affecting model availability for some users in our US5 region. Initial customer reports indicated errors preventing users from opening their models. We initiated our incident response process and declared a platform incident at 23:50 UTC. 

Root Cause 

Our investigation determined that a recent platform update inadvertently introduced a library dependency that caused a performance issue affecting model access in US5: Cloud - US East. This library change caused system processes to hold model resources longer than intended, creating a queue of pending requests. Users experienced this as model busy or slower performance when opening or saving models. 

Recovery 

Our engineering team executed a zero-downtime rollback to the previous stable version, which reverted the problematic library dependency. This cleared the backlog of pending requests. Our teams validated the recovery by conducting functional checks, running smoke tests, and closely monitoring our performance dashboards. These actions confirmed that service and performance had returned to normal levels. As the backlog of requests cleared, model access and performance steadily returned to expected levels and no further model lock errors were observed.  

Full service was restored at 01:34 UTC on February 26, 2026. 

Corrective & Preventative Actions 

To prevent similar incidents in the future, we are implementing the following improvements: 

  • Implementing alerting to detect request queue buildups earlier, providing our teams with advance visibility before customer impact occurs. 

  • Adding validation procedures that test library dependencies to platform updates to identify potential issues before deployment. 

These actions are part of our ongoing commitment to improving platform resilience and maintaining reliable service for all customers. 

We apologize for any impact this issue may have had on your business operations. We are continuously strengthening our systems and procedures to ensure we avoid future disruptions to your business and users. 

If you have further questions or concerns, please visit our Support website. We appreciate your patience during this incident and value the trust you place in Anaplan.

Posted Mar 06, 2026 - 17:03 UTC

Resolved

We have confirmed that the issue is now resolved.

We deeply apologize for any impact this issue may have caused. We appreciate your patience and partnership as we worked through this issue.

We will follow up within 7 business days with a detailed root cause analysis (RCA) that will be shared on our Status Page. If you have any question or concerns, please do not hesitate to contact us at Anaplan Support.
Posted Feb 26, 2026 - 02:14 UTC

Update

Service has now been restored; you should now be able to resume normal activities.

We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support. We will provide a final update to you when we consider this situation fully resolved.
Posted Feb 26, 2026 - 02:02 UTC

Update

Service has now been restored; you should now be able to resume normal activities.

We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support. We will provide a final update to you when we consider this situation fully resolved.
Posted Feb 26, 2026 - 01:33 UTC

Monitoring

The team identified the issue and is working diligently to mitigate it.

We will provide updates every 30 minutes or upon resolution.
Posted Feb 26, 2026 - 01:14 UTC

Investigating

We are currently investigating an issue resulting in some customers not being able to load new models.

We are working to resolve this issue as quickly as possible and will provide updates every 30 minutes or upon resolution.
Posted Feb 26, 2026 - 00:50 UTC
This incident affected: us5: Cloud - US East.