Unplanned Outage
Incident Report for Anaplan
Postmortem

This platform service interruption was a continuation of the incident posted earlier the same day, which is summarized below:

On April 28 at 12:42 UTC, Anaplan engineers were alerted to an issue regarding users being unable to log into the platform. Upon investigation, it was identified that this issue was caused by a recent release which included some code intended for a future release.  This change prevented necessary communication between Anaplan models and the database, causing some models to encounter an error when trying to synchronize their statuses with the database. As a result, it was possible for models to fail to load when access was attempted.  We took the required steps to revert the code merge which restored access to the platform.

We are reviewing and improving our internal release and change management process to ensure this does not happen again, which will include adding additional verification checks as well as application changes to make the platform more resilient.

We understand the impact that this type of interruption can have on your experience, and we are working diligently to improve our systems and processes to help prevent this from occurring again. We appreciate your understanding, and we thank you for being a valued Anaplan customer.

Posted May 04, 2021 - 19:41 PDT

Resolved
We have confirmed with customers that the Anaplan platform is now accessible. We apologize for any inconvenience that this issue may have caused. We appreciate your patience while we document a comprehensive root cause analysis. If you have any further questions, concerns, or continue to receive an error, please don't hesitate to contact us at support@anaplan.com.
Posted May 04, 2021 - 19:39 PDT
Monitoring
Our engineers have restored service to the Anaplan platform, but we have identified a subset of customers that continue to have residual issues with Application Lifecycle Management functionality. Our Support teams will be working individually with these impacted customers to resolve the issue.

Because the majority of customers are experiencing no issues, instead of posting frequent updates to the Status page, we will provide a root cause analysis and resolution update once all customers are fully operational.

If you have any questions, concerns, or are experiencing issues, please don’t hesitate to contact us at support@anaplan.com. Once again, we greatly appreciate your patience and understanding.
Posted Apr 28, 2021 - 09:24 PDT
Update
We have isolated the components impacted by the reported service interruption and have all engineers actively working to restore service to the Anaplan platform. A quick resolution is our top priority and we are committed to further investigating the root cause of this issue. We apologize for any inconvenience that this may have caused and appreciate your continued patience while we work toward a resolution. Thank you for being a valued Anaplan customer.
Posted Apr 28, 2021 - 08:22 PDT
Identified
We have isolated the components impacted by the reported service interruption and have all engineers actively working to restore service to the Anaplan platform. A quick resolution is our top priority and we are committed to further investigating the root cause of this issue. We apologize for any inconvenience that this may have caused and appreciate your continued patience while we work toward a resolution. Thank you for being a valued Anaplan customer.
Posted Apr 28, 2021 - 08:20 PDT
Monitoring
Our engineers have restored service to the Anaplan platform. You should now be able to resume normal activities. We will continue to monitor the situation to ensure no additional issues arise and contact our customers to validate and confirm the platform is functional and operational. If you have any questions, concerns, or continue to receive errors, please don't hesitate to contact us at support@anaplan.com. Once again, we are extremely appreciative of your patience and understanding.
Posted Apr 28, 2021 - 08:08 PDT
Update
We have identified the issue preventing customers accessing the Anaplan Platform. Our engineers are actively working to restore service and determine the root cause. Updates will be posted to this page as they become available.
Posted Apr 28, 2021 - 08:00 PDT
Identified
We have isolated the components impacted by the reported service interruption and have all engineers actively working to restore service to the Anaplan platform. A quick resolution is our top priority and we are committed to further investigating the root cause of this issue. We apologize for any inconvenience that this may have caused and appreciate your continued patience while we work toward a resolution. Thank you for being a valued Anaplan customer.
Posted Apr 28, 2021 - 07:32 PDT
Investigating
We are receiving reports of our customers experiencing issues accessing the Anaplan platform. Our engineers are aware and actively investigating. We will provide regular updates on this page until the issues are resolved. We apologize for the inconvenience this may be causing and appreciate your patience.
Posted Apr 28, 2021 - 06:49 PDT
This incident affected: Anaplan Platform US-1 and Anaplan Platform EU-2.