Platform Alerts

Incident Report for Anaplan

Postmortem

On November 13, 2024, at 00:10 UTC, our alerting notified us of a back-end component of the authorization service not performing as expected. At this point there was no impact to customers.

We restarted the impacted component, but errors continued to persist. We performed a rolling restart of the Authorization service. However, the rolling restart failed, which resulted in all customers being unable to access the platform at 01:39 UTC. This issue affected Anaplan Data Center — U.S. East, Anaplan Data Center — U.S. West, Anaplan Data Center — Germany, Anaplan Data Center — Netherlands, Anaplan Google Cloud Public — U.S. East, Anaplan Google Cloud Public — Japan, Anaplan Amazon Cloud Public — U.S., and Anaplan Amazon Cloud Public — Europe.

Our investigations found that a connectivity issue caused the restart failure. We investigated the connectivity issue but didn't find any outliers. As a result, we performed a rolling restart of a subservice within the authorization service that was impacted by the connectivity issue. Shortly after the restart, access to the platform was restored at 02:38 UTC.

At 03:09 UTC, we started to receive reports that integration within CloudWorks™ weren't being processed. We identified that integrations were in a stuck state because of an authentication issue. To resolve this issue, we completed a rolling restart of multiple sub-services within the CloudWorks™ service. Integrations started to process around 05:38 UTC. However, due to the delay in restoring the CloudWorks™ service, there was a large backlog of integrations. This resulted in a degraded performance of the CloudWorks™ service. At 06:44 UTC, the integration backlog had cleared, and performance was restored in Anaplan Data Center — U.S. East, Anaplan Data Center — U.S. West, Anaplan Google Cloud Public — Japan, Anaplan Amazon Cloud Public — U.S., and Anaplan Amazon Cloud Public — Europe.

CloudWorks™ performance remained degraded in Anaplan Data Center — Germany, Anaplan Data Center — Netherlands, and Anaplan Google Cloud Public — U.S. East as the backlog of integrations remained high. We increased resource allocation for CloudWorks™ within these regions to attempt to speed up the processing of the backlog. At 08:24 UTC, the integration backlog had cleared, and performance was restored in Anaplan Data Center — Germany and Anaplan Google Cloud Public — U.S. East.

CloudWorks™ integrations within Anaplan Data Center — Netherlands remained degraded. We continued to review the service and made further increases, both vertically and horizontally, to resources. This helped the backlog of integrations process faster. However, until the backlog was completely cleared, integration processing continued to be slower than usual. The backlog was completed by 12:44 UTC and CloudWorks™ performance was fully restored.

To prevent a recurrence, we have conducted a thorough analysis of the network, infrastructure, and application services. We identified that there was a performance degradation to one of our firewalls due to resource exhaustion. This resulted from an existing policy misconfiguration. The firewall was never inoperable, but inbound and outbound traffic was impacted for a period, affecting most customers from around 01:12 UTC. The firewall degradation also contributed to the failure of the rolling restart of the authorization service. We immediately updated the firewall policy to prevent the resource exhaustion that occurred. Additionally, we are conducting a full review of all firewall policies to ensure no further misconfigurations exist. We have also looked at the CloudWorks™ service and found improvements that can be made to improve the processing of integrations. We will be adding further capacity to the CloudWorks™ service to enable new configurations to be applied to provide more processing headroom. These mitigations are in progress, and we expect improvements to service over the next few days.

We sincerely apologize for the impact this has had on your customers' business operations. We know these issues can cause trouble for your customers' business and users. We are always improving our systems and procedures to prevent similar issues from happening again.

If you have any further questions or concerns, please contact Anaplan Customer Care. Thank you for your patience during this situation and thank you for being an Anaplan customer.

Posted Nov 21, 2024 - 22:32 UTC

Resolved

We have confirmed that the issue is now resolved.

We deeply apologize for any impact this issue may have caused. We appreciate your patience and partnership as we worked through this issue.

We will follow up within 7 business days with a detailed root cause analysis (RCA) that will be shared on our Status Page. If you have any question or concerns, please do not hesitate to contact us at Anaplan Support.
Posted Nov 13, 2024 - 14:10 UTC

Update

CloudWorks continues to function as expected. The integration backlog is processing and will take time to clear back to normal levels.

We are closely monitoring progress and will provide an update in 60 minutes or upon resolution.
Posted Nov 13, 2024 - 13:11 UTC

Monitoring

General CloudWorks performance has improved and the service now appears to be functioning as expected. Integration back log continues to take time to clear back to normal levels and we are closely monitor activity until it is complete.

We will provide an update in 30 minutes or upon resolution
Posted Nov 13, 2024 - 12:40 UTC

Update

We have adjusted how we have scaled the resources and are currently monitoring progress. We have seen improvements; however, we expect the integration back log to continue to take time to clear back to normal levels.

We are currently assessing further options and will provide an update in 30 minutes or upon resolution.
Posted Nov 13, 2024 - 12:03 UTC

Update

We are aware that some CloudWorks and PlanIQ integrations continue to run slowly in Anaplan Data Center - Netherlands. This is due to a build up of integrations while the platform was unavailable.

We have adjusted how we have scaled the resources and are currently monitoring progress. We will provide an update in 30 minutes or upon resolution.
Posted Nov 13, 2024 - 11:33 UTC

Update

We are aware that some integrations continue to run slowly in Anaplan Data Center - Netherlands. This is due to a build up of integrations while the platform was unavailable.

We have scaled up the resources to improve the overall processing time of integrations but have not seen any significant improvement. We are currently assessing further options and will provide an update in 30 minutes or upon resolution.
Posted Nov 13, 2024 - 11:02 UTC

Update

We are aware that some integrations continue to run slowly in Anaplan Data Center - Netherlands. This is due to a build up of integrations while the platform was unavailable.

We have scaled up the resources to improve the overall processing time of integrations and are currently monitoring progress.

We will provide a further update in 30 minutes or upon resolution.
Posted Nov 13, 2024 - 10:34 UTC

Update

Some integrations continue to run slowly in the following regions:

Anaplan Data Center - Netherlands

This is due to a build up of integrations while the platform was unavailable. We are currently processing the backlog and will provide a further update in 30 minutes or upon resolution.

We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support.
Posted Nov 13, 2024 - 10:04 UTC

Update

We are aware that some integrations continue to run slowly in the following regions:

Anaplan Data Center - Netherlands

This is due to a build up of integrations while the platform was unavailable. We are currently processing the backlog and will provide a further update in 30 minutes or upon resolution. Integrations in Anaplan Data Center - Germany are now running normally.

We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support.
Posted Nov 13, 2024 - 09:36 UTC

Identified

We are aware that some integrations are running slowly in the following regions:
Anaplan Data Center - Netherlands
Anaplan Data Center - Germany
This is due to a build up of integrations while the platform was unavailable. We are currently processing the backlog and will provide a further update in 30 minutes or upon resolution.
We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support.
Posted Nov 13, 2024 - 09:12 UTC

Monitoring

Service has now been restored; you should now be able to resume normal activities.

We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support. We will provide a final update to you when we consider this situation fully resolved.
Posted Nov 13, 2024 - 08:12 UTC

Update

Thank you for your patience as we continue to investigate this issue. Currently, we do not yet have a time to resolution. We will continue to provide updates every 30 minutes as we work to resolve this issue as quickly as possible.
Posted Nov 13, 2024 - 07:38 UTC

Update

Thank you for your patience as we continue to investigate this issue. Currently, we do not yet have a time to resolution. We will continue to provide updates every 30 minutes as we work to resolve this issue as quickly as possible.
Posted Nov 13, 2024 - 06:59 UTC

Update

Thank you for your patience as we continue to investigate this issue. Currently, we do not yet have a time to resolution. We will continue to provide updates every 30 minutes as we work to resolve this issue as quickly as possible.
Posted Nov 13, 2024 - 06:30 UTC

Update

Thank you for your patience as we continue to investigate this issue. Currently, we do not yet have a time to resolution. We will continue to provide updates every 30 minutes as we work to resolve this issue as quickly as possible.
Posted Nov 13, 2024 - 06:01 UTC

Update

Thank you for your patience as we continue to investigate this issue. Currently, we do not yet have a time to resolution. We will continue to provide updates every 30 minutes as we work to resolve this issue as quickly as possible.
Posted Nov 13, 2024 - 05:29 UTC

Update

Thank you for your patience as we continue to investigate this issue. Currently, we do not yet have a time to resolution. We will continue to provide updates every 30 minutes as we work to resolve this issue as quickly as possible.
Posted Nov 13, 2024 - 05:00 UTC

Update

We are currently investigating an issue impacting customers’ ability to run Cloudworks integrations.

We are working to resolve this issue as quickly as possible and will provide updates every 30 minutes or upon resolution.
Posted Nov 13, 2024 - 04:32 UTC

Investigating

We are currently investigating an issue impacting customers’ ability to run Cloudworks integrations.

We are working to resolve this issue as quickly as possible and will provide updates every 30 minutes or upon resolution.
Posted Nov 13, 2024 - 03:58 UTC

Monitoring

Service has now been restored; you should now be able to resume normal activities.

We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support. We will provide a final update to you when we consider this situation fully resolved.
Posted Nov 13, 2024 - 02:45 UTC

Update

The investigation is still in progress as we see the issue is impacting customers’ ability to access the Anaplan Platform.

We are working to resolve this issue as quickly as possible and will provide updates every 30 minutes or upon resolution.
Posted Nov 13, 2024 - 02:25 UTC

Update

We still investigating the issue impacting customers’ ability to access the Anaplan Platform.

We are working to resolve this issue as quickly as possible and will provide updates every 30 minutes or upon resolution.
Posted Nov 13, 2024 - 02:03 UTC

Investigating

We are currently investigating an issue impacting customers’ ability to access the Anaplan Platform.

We are working to resolve this issue as quickly as possible and will provide updates every 30 minutes or upon resolution.
Posted Nov 13, 2024 - 01:47 UTC
This incident affected: us1: Data Center - US East, us2: Data Center - US West, eu1: Data Center - Netherlands, eu2: Data Center - Germany, us5: Cloud - US East, ap1: Cloud - Japan, and us7: Cloud - US.