November 28 Service Disruption
Incident Report for Anaplan
Postmortem

Dear Anaplanners,

Anaplan recently experienced a short platform outage that occurred on November 28, 2017 from approximately 12:30 p.m. to 1:10 p.m. PDT, which impacted a small subset of customers. As a follow-up to this unplanned outage, we wanted to ensure we were providing additional information and assurances regarding the cause and solutions for this outage.

In the process of updating our infrastructure as we continue to scale, our Master DNS server unexpectedly failed. As expected, the secondary DNS server was engaged and performed as expected while the Master DNS server was re-built. When the re-build was completed, the DNS services were not properly switched back to the Master DNS server before the secondary DNS server’s operation lifecycle completed. As a result of this unfortunate human error, the November 28 outage occurred.

Since then, DNS monitoring has been activated as part of our planned infrastructure process and hardware improvements.

We appreciate your patience during this outage and as we institute these changes. As always, thank you for being a valued Anaplan customer.

Posted Dec 07, 2017 - 16:50 UTC

Resolved
Our engineers have restored service to the platform and we are receiving reports of users accessing their models successfully again. We will continue monitoring and will update this page if we have any further reports of issues. We will post the root cause analysis once this is available. We apologize for any inconvenience this has caused. If you have any questions please reach out to Support@anaplan.com
Posted Nov 28, 2017 - 21:21 UTC
Investigating
We have received some reports of users receiving errors when opening models. Our engineers are aware and are actively investigating. We will provide an update as we have more information. If you have any questions, please contact us at support@anaplan.com. We apologize for any inconvenience this may cause.
Posted Nov 28, 2017 - 20:51 UTC