Platform Alerts

Incident Report for Anaplan

Postmortem

On December 5, 2025, beginning at 08:47 UTC, an outage within Cloudflare's infrastructure resulted in widespread internet disruption. The failure led to large-scale connectivity interruption for numerous cloud platforms. As a result, the Anaplan platform was unavailable for 25 minutes. This incident was triggered by a configuration change deployed by Cloudflare that contained a latent software bug. The issue originated entirely outside of the Anaplan environment. However, as Cloudflare is a critical component of the internet ecosystem, this failure had a direct downstream impact on our customers' ability to access the Anaplan platform. The Anaplan platform was unavailable from 08:47 UTC to 09:12 UTC. All Anaplan regions were impacted by this external event. 

 Root Cause 

Cloudflare, a major provider of internet routing and security services, initiated a global configuration update intended to enhance their Web Application Firewall (WAF). This update was deployed in two parts. The second part of the change, which was rapidly propagated across their network, exposed a previously undetected bug in their software. 

This bug caused an error state in a portion of Cloudflare's proxy servers. This led their systems to return HTTP 500 (Internal Server Error) responses instead of forwarding user traffic. This failure directly interrupted the ability of our customers to access the platform. At 09:11 UTC, Cloudflare identified and reverted the faulty configuration change.  Full service to the Anaplan platform was restored at 09:12 UTC, once the fix was fully propagated. 

Our Response and Recovery 

Our monitoring systems detected login and routing anomalies, triggering an immediate incident response from our technical teams. Within minutes of initiating our investigation, we isolated the issue to the Cloudflare outage. 

Throughout the event, we monitored all Anaplan services to ensure our platform components remained healthy and to validate that the impact stemmed solely from the upstream provider. As Cloudflare rolled out their fix, we evaluated recovery to confirm that service stability was returning for all customers. 

Corrective and Preventative Actions 

Although this was an external global internet outage, we hold ourselves accountable for the experience our customers have with the Anaplan platform. We are taking several steps to strengthen our resilience: 

  • We have escalated this incident through Cloudflare's senior leadership and have participated in a joint post-incident review. Cloudflare has enacted a stabilization period for the remainder of the year to focus on their mitigation and resilience work. We will continue to partner with them to ensure their corrective actions—specifically regarding safer deployment practices and 'fail-open' error handling — are fully implemented to prevent recurrence. 
  • We are improving our internal visibility into provider-level network anomalies to enable earlier detection. This will help us communicate more effectively with our customers. 
  • We are evaluating architectural opportunities to reduce sensitivity to single-provider global events. 

We apologize for the disruption this global outage has caused to your business operations. We understand that downtime — no matter the source — has a real impact.  

If you have further questions or concerns, please visit our Support website. We appreciate your patience during this incident and value the trust you place in Anaplan

Posted Dec 11, 2025 - 16:00 UTC

Resolved

We have confirmed that the issue is now resolved.

We deeply apologize for any impact this issue may have caused. We appreciate your patience and partnership as we worked through this issue.

We will follow up within 7 business days with a detailed root cause analysis (RCA) that will be shared on our Status Page. If you have any question or concerns, please do not hesitate to contact us at Anaplan Support.
Posted Dec 05, 2025 - 09:31 UTC

Update

Service has now been restored; you should now be able to resume normal activities.

We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support. We will provide a final update to you when we consider this situation fully resolved.
Posted Dec 05, 2025 - 09:26 UTC

Monitoring

Service seem to be recovering; you should now be able to resume normal activities.
Initial investigation confirmed it to be a Cloudflare issue.
We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support. We will provide a final update to you when we consider this situation fully resolved.
Posted Dec 05, 2025 - 09:18 UTC

Investigating

We are currently investigating an issue impacting customers’ ability to access the Anaplan Platform.

We are working to resolve this issue as quickly as possible and will provide updates every 30 minutes or upon resolution.
Posted Dec 05, 2025 - 09:08 UTC
This incident affected: us1: Data Center - US East, us2: Data Center - US West, eu1: Data Center - Netherlands, eu2: Data Center - Germany, eu4: Cloud - Europe, us5: Cloud - US East, ap1: Cloud - Japan, us7: Cloud - US, us3: Cloud - US, us4: Cloud - US, ca1: Cloud - Canada, au1: Cloud - Australia, eu3: Cloud - Europe, me1: Cloud - Saudi Arabia, in1: Cloud - India, id1: Cloud - Indonesia, gb1: Cloud - UK, ae1: Cloud - UAE, and us9: Cloud - US.