Platform Alerts

Incident Report for Anaplan

Postmortem

On June 17, 2025, we received notifications that customers were encountering an error when attempting to trigger CloudWorks™ integration jobs via API. Initially, it appeared that this issue affected all regions. However, we subsequently identified that only the following regions were affected:

  • ap1: Cloud - Japan
  • au1: Cloud - Australia
  • ca1: Cloud - Canada
  • eu1: Data Center - Netherlands
  • eu2:  Data Center - Germany
  • us1: Data Center - US East
  • us2: Data Center - US West
  • us5: Cloud - US East
  • us7: Cloud - US

At 11:10 UTC, we declared an incident and quickly ascertained that the issue was related to missing domain records. We identified that an update had been made the previous day to improve the standardization of our external routing configuration. This update was reverted, and we started to see successful requests to the CloudWorks API across affected regions. Full service was restored at 12:37 UTC.

We have reviewed why the update resulted in adverse behavior. The routing records for CloudWorks use a specific approach, which we have gradually phased out from other services. The update removed the path for this approach, resulting in requests being unable to resolve.

To stop this issue from happening again, we're making several changes to our process. We're updating the routing records for CloudWorks before reinstating the original update. We are enhancing the CloudWorks APIs external monitoring to better replicate the customer journey and improve our ability to identify issues proactively.

We apologize for any impact this issue may have had on your business operations. We're continuously strengthening our systems and procedures to ensure we avoid future disruptions to your business and users.

If you have further questions or concerns, please visit the Anaplan Support website. Thank you for your patience during this situation and thank you for being an Anaplan customer.

Posted Jun 20, 2025 - 08:40 UTC

Resolved

We have confirmed that the issue is now resolved.

We deeply apologize for any impact this issue may have caused. We appreciate your patience and partnership as we worked through this issue.

We will follow up within 7 business days with a detailed root cause analysis (RCA) that will be shared on our Status Page. If you have any question or concerns, please do not hesitate to contact us at Anaplan Customer Care.
Posted Jun 17, 2025 - 12:37 UTC

Monitoring

Service has now been restored; all CloudWorks integrations can be triggered as normal.

We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support. We will provide a final update to you when we consider this situation fully resolved.
Posted Jun 17, 2025 - 12:22 UTC

Update

We have identified the likely cause of the issue, and we are focused right now on restoring service as quickly as possible. We have evaluated the steps needed to roll back a recent change to alleviate the issue.

Currently, we do not yet have a time to resolution. We will provide further updates in 30 minutes or sooner as additional information becomes available.
Posted Jun 17, 2025 - 12:12 UTC

Identified

We have identified the likely cause of the issue, and we are focused right now on restoring service as quickly as possible.

Currently, we do not yet have a time to resolution. We will provide further updates in 30 minutes or upon resolution.
Posted Jun 17, 2025 - 11:43 UTC

Investigating

We are currently investigating an issue impacting customers’ ability to run Cloudworks integrations via API.

We are working to resolve this issue as quickly as possible and will provide updates every 30 minutes or upon resolution.
Posted Jun 17, 2025 - 11:20 UTC
This incident affected: us1: Data Center - US East, us2: Data Center - US West, eu1: Data Center - Netherlands, eu2: Data Center - Germany, eu4: Cloud - Europe, us5: Cloud - US East, ap1: Cloud - Japan, us7: Cloud - US, us3: Cloud - US, us4: Cloud - US, ca1: Cloud - Canada, au1: Cloud - Australia, eu3: Cloud - Europe, me1: Cloud - Saudi Arabia, in1: Cloud - India, id1: Cloud - Indonesia, gb1: Cloud - UK, and ae1: Cloud - UAE.