Platform Alerts
Incident Report for Anaplan
Postmortem

On December 15, 2023, at 11:24 UTC, we detected errors that indicated a potential impact to CloudWorks integrations. Upon further investigation, we identified that customers may have experienced slow or failed integrations on the following Anaplan data centers: U.S. East; U.S. West; Netherlands; Germany; Anaplan Google Cloud Public - Japan, Anaplan Google Cloud Public - U.S. East; and Anaplan Amazon Cloud Public – U.S.

Initial investigation isolated that the issue was related to a back-end service not operating as expected. Further investigation identified that an internal service was running a new job that had locked up the impacted back-end service. We stopped the job and restarted the backend service; however, the issue resulted in a build-up of Cloudworks integrations, which resulted in integrations running slowly. To speed-up the processing of the backlogged integrations, we added additional resources to the underlying processing component.  Once all pending Cloudworks integrations completed, we confirmed service was restored at 14:43 UTC.

We apologize for any impact this issue might have had on your business operations. We’re continuously strengthening our systems and procedures to ensure we avoid future disruption to your business and users.

To avoid a reoccurrence of this issue, we have removed the internal service from running jobs on the production instance of the impacted back-end service going forward. We have also updated our monitoring on the back-end service and on CloudWorks to ensure we identify any potential issues of this nature much quicker in the future to prevent customer impact.

If you have further questions or concerns, please visit our Anaplan Support website. Thank you for your patience during this situation and thank you for being an Anaplan customer.

Posted Dec 20, 2023 - 15:54 UTC

Resolved
We have confirmed that the issue is now resolved.

We deeply apologize for any impact this issue may have caused. We appreciate your patience and partnership as we worked through this issue.

We will follow up within 7 business days with a detailed root cause analysis (RCA) that will be shared on our Status Page. If you have any question or concerns, please do not hesitate to contact us at Anaplan Support.
Posted Dec 15, 2023 - 14:43 UTC
Update
We have identified the likely cause of the issue and have applied the remediation to restore service as quickly as possible. We are carrying out further validation to ensure services are back to normal.

We will provide further updates in the next hour or upon resolution.
Posted Dec 15, 2023 - 14:12 UTC
Identified
We have identified the likely cause of the issue, and we are focused right now on restoring service as quickly as possible. Currently, we do not yet have a time to resolution. We will provide further updates in 30 minutes or upon resolution.
Posted Dec 15, 2023 - 13:07 UTC
Update
We are currently investigating an issue impacting customers’ ability to run Cloudworks integrations.

We are working to resolve this issue as quickly as possible and will provide updates every 30 minutes or upon resolution.
Posted Dec 15, 2023 - 12:13 UTC
Investigating
We are currently investigating an issue impacting customers’ ability to run Cloudworks integrations.

We are working to resolve this issue as quickly as possible and will provide updates every 30 minutes or upon resolution.
Posted Dec 15, 2023 - 12:08 UTC
This incident affected: Anaplan Data Center - US East, Anaplan Data Center - US West, Anaplan Data Center - Netherlands, and Anaplan Data Center - Germany.