Platform Alerts
Incident Report for Anaplan
Postmortem

On May 23, 2024, at 12:14 UTC, we started to receive errors indicating that models were inaccessible in Anaplan Amazon Cloud – Europe.   

Our team established that a change to authentication interactions within the platform had been deployed around 10:35 UTC. This change was identified as the probable cause of the incident and was rolled back. The rollback was completed by 12:47 UTC. All local testing and associated monitoring were confirmed as healthy, and the incident was closed at 12:56 UTC.  

At 13:10 UTC, we received feedback that some customer models remained inaccessible. The incident was re-opened, and we found that a workspace migration had automatically started once the change had been reverted. This migration was required to move workspaces to fresh components; however, workspaces were inaccessible until the migration was completed.   

 We closely monitored the migration and by 13:24 UTC only two workspaces remained in progress. These workspaces were reviewed and at 13:43 UTC it was decided that manual intervention was required to expedite the process. The migration job was manually restarted and by 14:03 UTC all workspaces were available. We continued to monitor the platform to ensure no further issues were identified. The incident was resolved at 14:31 UTC.  

 To prevent a recurrence of this issue, we are updating our approach when implementing these types of changes. Our aim is to make the process more efficient, as well as, improving the rollback mechanism to avoid disruption in future. In addition, we are implementing additional alerting and monitoring for this scenario to ensure we know about this even earlier if the same scenario were to arise in future.  

 We apologize for any impact this issue may have had on your business operations. We are continuously strengthening our systems and procedures to ensure we avoid future disruptions to your business and users.  

 If you have further questions or concerns, please visit the Anaplan Support website. Thank you for your patience during this situation and thank you for being an Anaplan customer.

Posted May 30, 2024 - 19:11 UTC

Resolved
We have confirmed that the issue is now resolved.

We deeply apologize for any impact this issue may have caused. We appreciate your patience and partnership as we worked through this issue.

We will follow up within 7 business days with a detailed root cause analysis (RCA) that will be shared on our Status Page. If you have any question or concerns, please do not hesitate to contact us at Anaplan Support.
Posted May 23, 2024 - 12:56 UTC
Monitoring
Service has now been restored; you should now be able to resume normal activities.

We will continue to monitor the platform to ensure no additional issues arise. If you have any questions, concerns, or continue to experience issues, please do not hesitate to contact Anaplan Support. We will provide a final update to you when we consider this situation fully resolved.
Posted May 23, 2024 - 12:49 UTC
Identified
We have identified the likely cause of the issue, and we are focused right now on restoring service as quickly as possible. We expect this activity to take around 15 minutes and will provide a further update shortly.
Posted May 23, 2024 - 12:45 UTC
Investigating
We are currently investigating an issue resulting in some customers not being able to load models.

We are working to resolve this issue as quickly as possible and will provide updates every 30 minutes or upon resolution.
Posted May 23, 2024 - 12:34 UTC
This incident affected: Anaplan Amazon Cloud - Europe.